Menü

  Login

  Shoutbox

  Forum » Fragen zu Ilch » Anleitungen etc. » Problem mit News Extended 1.4a und SQL??


Problem mit News Extended 1.4a und SQL??
whistler
Grünschnabel

User Pic

Posts: 2
# 18.06.2010 - 17:13:52
    zitieren



Hallo, ich habe ein problem
ich wollte auf unserer page bei den news youtube videos einfügen
ich habe dan das modul news extended 1.4a installiert aber hatte bei news erstellen kein video button, habe darauf hier im forum gelesen das man mal das bbcode 2.0 ausprobieren sollte, habe ich auch getan, jetzt habe ich einen video button, aber egal was ich auch für eine neue news erstelle kommt diese fehlermeldung:

MySQL Error:
1064 : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 2
in Query:
INSERT INTO `ic1_news` (news_title,user_id,news_time,news_...ws_text,html,`show`,archiv,endtime) VALUES ('dsds',1,NOW(),1023,0,'Allgemein','dsss','',1,2,)

Debug backtrace:
@ mysql.php:32 -- debug_bt()
@ mysql.php:50 -- db_check_error(...)
@ news.php:185 -- db_query(...)
@ admin.php:32 -- require_once(...)


bevor ich alles strubbelig mache, was kann ich tun???
mfg marcel
whistler
Grünschnabel

User Pic

Posts: 2
# 18.06.2010 - 23:10:33
    zitieren



danke habe es selber rausgefunden, bei der installation von extended 1.4a fragt er ob früher bbcode oder fck html verwendet wurde, hatte das falsche genommen, nun geht alles wundebar...
Muecke
Gast

User Pic

# 01.01.2011 - 14:34:47
    zitieren



moin,
ich habe ebenfalls Porbleme mit diesem modul.Ich erhalte folgenden Fehler
zuvor hatte ich bbcode 2.0 drauf und bei der installation angeklickt.

MySQL Error:
1064 : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ' news_text = "ggggg" WHERE news_id = "" LIMIT 1' at line 11
in Query:
UPDATE `ic1_news` SET news_title = "gggg", editor_id = "1", edit_time = NOW(), news_recht = "768", news_groups = "0", news_kat = "Allgemein", html = "", `show` = 1, archiv = 2, endtime = , news_text = "ggggg" WHERE news_id = "" LIMIT 1

Debug backtrace:
@ mysql.php:32 -- debug_bt()
@ mysql.php:50 -- db_check_error(...)
@ news.php:211 -- db_query(...)
@ admin.php:36 -- require_once(...)

ausserdem kann ich im admin menue News keine news mehr schreiben, die alten news sehe ich nicht mehr und kann sie daher auch nicht mehr editieren. hier meine testseite testseite http://treffpunkt-cod.square7.ch

LG
Muecke
Mairu
Administrator

User Pic

Posts: 1908
# 01.01.2011 - 15:33:17
    zitieren



Lad das Modul einfach nochmal hoch und achte dabei darauf, dass auch alle Dateien hochgeladen werden, sieht aus, als wäre deine admin/templates/news.htm einfach nicht die richtige.
Muecke
Gast

User Pic

# 01.01.2011 - 19:42:53
    zitieren



Hi,

habe ich gemacht das bbcode habe ich danach auch neu draufgezogen ich kann im Admin menue News schreiben bekomme dann aber diesen fehler hier :

MySQL Error:
1064 : You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ')' at line 2
in Query:
INSERT INTO `ic1_news` (news_title,user_id,news_time,news_...ws_text,html,`show`,archiv,endtime) VALUES ('blindtext',1,FROM_UNIXTIME(129390...60),1023,0,'','blindtext','',1,2,)

Debug backtrace:
@ mysql.php:32 -- debug_bt()
@ mysql.php:50 -- db_check_error(...)
@ news.php:191 -- db_query(...)
@ admin.php:36 -- require_once(...)

Auf der HP wo die news ercheinen sollte ist sie nicht, auch die alten news sind nicht mehr zu sehen.

was nun?
Muecke
Gast

User Pic

# 01.01.2011 - 19:50:19
    zitieren



hab noch was vergessen, die alten news sind nicht zu sehen ich kann also die alten news nicht sehen oder löschen +editieren, news einsenden scheint auch nicht zu gehen.

bevor ich alles neu aufgsetzt habe, habe ich einen test gemacht die news.php im content durch eine alte ersetzt> und danach waren alle zuvor geschriebenen news wieder da.

nach der neuinstallation war wieder alles weg wie zuvor beschrieben.
Muecke
Gast

User Pic

# 01.01.2011 - 20:17:52
    zitieren



Hallo Mairu,

problem gelöst das modul läuft nun. Danke für die Hilfe
honda_zicke
Grünschnabel

User Pic

Posts: 1
# 02.02.2013 - 16:09:43
    zitieren



Hallo Mairu,

ich hab den o.g. Fehler auch und komm aber grade nicht weiter.
Egal was ich mache, es tut sich nichts.



Kannst du mir helfen?
Mairu
Administrator

User Pic

Posts: 1908
# 04.02.2013 - 09:23:11
    zitieren



Der Fehler kommt, wenn man nicht alle Dateien der gleichen Version benutzt. Du hast also eine admin/news.php die nicht zur admin/templates/news.htm passt, in dem Fall ist das Template das Problem, weil Formularfelder fehlen, die vom Template geschickt werden müssen, du hast es also durch etwas anderes überschrieben.

Wenn du es (admin/templates/news.htm) neu vom Modul hochlädst, sollte es gehen.